Delays in updating payment information via Member Management

Incident Report for Club OS

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 18:07 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2026 - 18:04 EDT

Identified

We have identified an issue causing delays when updating payment information via Member Management. We are actively working to resolve the issue and process the records as soon as possible.
Posted Aug 05, 2026 - 17:51 EDT
This incident affected: MMS (ASF) (Web Application).